How To Update From 9.1?

Doug Hardie bc979 at
Wed Apr 11 05:25:33 UTC 2018

> On 10 April 2018, at 18:24, Drew Tomlinson <drew at> wrote:
> I've got an old system I'm trying to get current.
> # uname -a
> FreeBSD 9.1-RELEASE-p1 FreeBSD 9.1-RELEASE-p1 #0: Tue May  9 09:19:33 PDT 2017     drew at  amd64
> So I consult the handbook and various list posts and find that I should be able to use freebsd-update.  Specifically I've done:
> I've tried deleting /var/db/freebsd-update and doing the 'fetch install' over.  I've tried deleting /usr/src and downloading a new copy of 9.3 source code.
> Overall, I really don't know what I need to do as I've never done a binary update before.  I don't even know if 'src/src' looks reasonable but I thought I'd give it a try.  Can anyone point me in the right direction?  I'd appreciate the nudge.

This is a common issue for 9 and earlier systems.  I understand it may also affect some 10s.  Basically there are some patches available in various postings to bug reports.  If you find both of them, it should work, but you have to manually update as line numbers are not consistent.  The easier approach is probably to get a copy of freebsd-update from a newer system.  It's a script so that works fine.  I have used the script from 11.0 to upgrade some 9.x systems.

-- Doug

More information about the freebsd-questions mailing list