Trying to boot from a zfs external disk

Fabian Keil freebsd-listen at
Tue May 30 14:21:23 UTC 2017

Eduardo Lemos de Sa <eduardo.lemosdesa at> wrote:

> I installed FreeBSD-10.3-RELEASE in a internal hard disk (named, that
> time, as ada0) in a zpool called zeeroot. Now, I move this hard disk to
> a case (so, it is a external drive now) and it is recognized as da0.
> When I tried to boot it, the process start normally but stopped at the
> moment to mount partitions. Later, I used to solve problems like this
> (in UFS/UFS2 file systems) booting in a live system (memory stick or CD)
> and editing /etc/fstab, renaming devices. But now, there is only in
> my /etc/fstab:
> # Device        Mountpoint    FStype    Options        Dump    Pass#
> #/dev/ada0p2        none    swap    sw        0    0
> md99                    none    swap    sw,file=/usr/swap0,late 0       0
> I read and
>, further FreeBSD Handbook.
> In the two first, there is no mention about problems in boot stage using
> zfs.
> Further, I tried to find files under /etc/ called zfs.conf or zpool.conf
> or other mentions to ada0 (grep -r -i ada0 *): nothing.

In case of ZFS the root pool is specified in /boot/loader.conf
with a line like:

ZFS is supposed to figure out the location of the disk(s) itself.

> Thus, I do not how can solve this mount booting problem. Please, could
> you give some hint about?

This bug could explain why booting fails when you use an external disk:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list