Trying to boot from a zfs external disk

Eduardo Lemos de Sa eduardo.lemosdesa at
Tue May 30 11:10:43 UTC 2017


I installed FreeBSD-10.3-RELEASE in a internal hard disk (named, that time,
as ada0) in a zpool called zeeroot. Now, I move this hard disk to a case
(so, it is a external drive now) and it is recognized as da0. When I tried
to boot it, the process start normally but stopped at the moment to mount
partitions. Later, I used to solve problems like this (in UFS/UFS2 file
systems) booting in a live system (memory stick or CD) and editing
/etc/fstab, renaming devices. But now, there is only in my /etc/fstab:

# Device        Mountpoint    FStype    Options        Dump    Pass#
#/dev/ada0p2        none    swap    sw        0    0
md99                    none    swap    sw,file=/usr/swap0,late 0       0

I read and, further FreeBSD Handbook.

In the two first, there is no mention about problems in boot stage using

Further, I tried to find files under /etc/ called zfs.conf or zpool.conf or
other mentions to ada0 (grep -r -i ada0 *): nothing.

Thus, I do not how can solve this mount booting problem. Please, could you
give some hint about?

Thank you in advance



Eduardo Lemos de Sa
Professor Titular
Dep. Quimica da Universidade Federal do Paraná
fone: +55(41)3361-3300
fax:   +55(41)3361-3186

More information about the freebsd-questions mailing list