ZFS root on single SSD?

mtiger mtiger090 at gmail.com
Sat May 27 13:00:09 UTC 2017

Thank You Fabian,

I'm going to try pre-release 11.1 later today, I'm hoping this will be 
fixed. It seems like would be a common problem with ZFS and usb disks 
being installation options for so long now. Is this not a very common 

On 5/25/2017 6:00 AM, Fabian Keil wrote:
> mtiger <mtiger090 at gmail.com> wrote:
>> I have a similar situation. I have a nice ssd i am using through a usb
>> port. I can't install this ssd internally because there are no free sata
>> ports nor mounting slots. I would like to use ZFS on it, but I can't get
>> it to boot using the  ZFS options from the installer. I'm trying to use
>> version 11 memstick image of the FreeBSD installer.
>> Now if I leave the install media (on a usb flash drive) connected I can
>> boot the drive setup as ZFS no problem. If i remove the install media
>> and try to boot I get an error telling me it can't mount root. Power the
>> system on and off and the problem is still the same.
>> If I do the same installation and select UFS everything works fine every
>> time no matter what usb devices I'm using or have connected.
>> I've tried this on several machines but always with the same result.
>> I've also had the same result using usb external hard drives.
>> I've been through the handbook time and time again. I also get the same
>> problem if I install TrueOS which is using 12-Current. As long as the
>> install media is still connected it will boot the other drive setup for
>> ZFS. If I disconnect the install flash drive it will not boot.
> The behaviour you describe could be the result of this bug:
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=208882
> Fabian

More information about the freebsd-questions mailing list