ZFS root on single SSD?

Fabian Keil freebsd-listen at fabiankeil.de
Thu May 25 10:04:59 UTC 2017

mtiger <mtiger090 at gmail.com> wrote:

> I have a similar situation. I have a nice ssd i am using through a usb 
> port. I can't install this ssd internally because there are no free sata 
> ports nor mounting slots. I would like to use ZFS on it, but I can't get 
> it to boot using the  ZFS options from the installer. I'm trying to use 
> version 11 memstick image of the FreeBSD installer.
> Now if I leave the install media (on a usb flash drive) connected I can 
> boot the drive setup as ZFS no problem. If i remove the install media 
> and try to boot I get an error telling me it can't mount root. Power the 
> system on and off and the problem is still the same.
> If I do the same installation and select UFS everything works fine every 
> time no matter what usb devices I'm using or have connected.
> I've tried this on several machines but always with the same result. 
> I've also had the same result using usb external hard drives.
> I've been through the handbook time and time again. I also get the same 
> problem if I install TrueOS which is using 12-Current. As long as the 
> install media is still connected it will boot the other drive setup for 
> ZFS. If I disconnect the install flash drive it will not boot.

The behaviour you describe could be the result of this bug:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20170525/a62b8e37/attachment.sig>

More information about the freebsd-questions mailing list