A question about php in a jail

Ernie Luzar luzar722 at gmail.com
Tue Jan 17 05:35:21 UTC 2017

James B. Byrne via freebsd-questions wrote:
> This past week I have been setting up a jail for a drupal7 website.  I
> am now at the point where I need to update the modules and I would
> like to employ the drush cli utility.  To install this on a Drupal7
> website it is suggested to run this command in the Drupal document
> root:
> php -r
> "readfile('https://s3.amazonaws.com/files.drush.org/drush.phar');" >
> drush
> However, when I run this inside the jail then I see this error,
> PHP Warning:  readfile(): Unable to find the wrapper "https" - did you
> forget to enable it when you configured PHP? in Command line code on
> line 1
> PHP Warning: 
> readfile(https://s3.amazonaws.com/files.drush.org/drush.phar): failed
> to open stream: No such file or directory in Command line code on line
> 1.
> If I run the same command on the host system of the jail then I do not
> get this error.  What am I missing with respect to the jailed setup?

I have no idea what Drupal is and you provided no details about how you 
populated the jail with it. So just a shot in the dark.

Sounds like your jail does not have public internet access. Is the jails 
IP address being NATed by your hosts firewall?

Issuing "whois" from with in your running jail should return 
results if the jail/host firewall is configured correctly.

You really need to post details about what steps you did before more 
people can help you.

More information about the freebsd-questions mailing list