A question about php in a jail

James B. Byrne byrnejb at harte-lyne.ca
Sat Jan 14 00:17:09 UTC 2017

This past week I have been setting up a jail for a drupal7 website.  I
am now at the point where I need to update the modules and I would
like to employ the drush cli utility.  To install this on a Drupal7
website it is suggested to run this command in the Drupal document

php -r
"readfile('https://s3.amazonaws.com/files.drush.org/drush.phar');" >

However, when I run this inside the jail then I see this error,

PHP Warning:  readfile(): Unable to find the wrapper "https" - did you
forget to enable it when you configured PHP? in Command line code on
line 1
PHP Warning: 
readfile(https://s3.amazonaws.com/files.drush.org/drush.phar): failed
to open stream: No such file or directory in Command line code on line

If I run the same command on the host system of the jail then I do not
get this error.  What am I missing with respect to the jailed setup?

***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
 Do NOT open attachments nor follow links sent by e-Mail

James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3

More information about the freebsd-questions mailing list