[Crosspost] Host losing network connectivity when jail is up after 21 minutes

Olivier Mauras olivier at mauras.ch
Thu Aug 24 09:23:48 UTC 2017

Sorry for crossposting from https://groups.google.com/a/hardenedbsd.org/forum/#!topic/users/tADY5vVqxew I hope it's acceptable


I have HardenedBSD 11.1 installed as a KVM guest with static route and a single public IP directly routed to internet by my provider's gateway.
I have two jails running on this guest, one running an sshd instance the other one a powerdns-recursor instance. Both jails are on a private subnet NATed by PF and running HBSD 11.1 as well.

If any of the jail is running, the host will lose network connectivity after ~21 minutes, and there is no relevant event in the logs - like really nothing - that could help pinpoint where the issue is coming from. 
When I stop the jail service, network connectivity gets back immediately. When I start the jail service again, network is still up for the next 21 minutes...

I've tried switching network interface driver from virtio to e1000 without any success as the behaviour is still the same.

Would someone have an idea to help tracking down this issue?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20170824/bfa67f58/attachment.sig>

More information about the freebsd-questions mailing list