How to boot from a zfs external disk?

Boris Samorodov bsam at
Wed Aug 23 13:27:02 UTC 2017

23.08.2017 15:29, Eduardo Lemos de Sa пишет:
> Dear
> A year ago, I installed 10.3-RELEASE in a internal notebook hard-drive (zfs
> formated, with pool named "zeeroot"). Now, I moved this hard drive to a
> case intending use it as a portable FreeBSD machine. In past, this hard
> disk was a /dev/ada0 device and now, of course, it assumes a name /dev/da0.
> When I tried to boot the initial process is ok, but when partitions an > filesystem are supposed to be mounted, I got a error and a request to
> specify from where I want to boot.
> When I typed "?" to see avaliable options, I got the result ( a photo took
> from my cell phone):

There is no zfs remnants there. Seems you lack zfs kernel loadable
modules. You may add following lines to /boot/loader.conf:

Or do the same from boot command line.

>   I tried several of them including:
> zfs:zeeroot
> Please, could you give some hint about to procedure?
> Thanks in advance for your attention
> Eduardo
> PS.: /dev/ada0 is the actual internal hard disk on the machine wheres I
> tried to boot. So, it is not a option

WBR, Boris Samorodov (bsam)
FreeBSD Committer, The Power To Serve

More information about the freebsd-questions mailing list