How to boot from a zfs external disk?

Eduardo Lemos de Sa eduardo.lemosdesa at
Wed Aug 23 12:29:32 UTC 2017


A year ago, I installed 10.3-RELEASE in a internal notebook hard-drive (zfs
formated, with pool named "zeeroot"). Now, I moved this hard drive to a
case intending use it as a portable FreeBSD machine. In past, this hard
disk was a /dev/ada0 device and now, of course, it assumes a name /dev/da0.
When I tried to boot, the initial process is ok, but when partitions and
filesystem are supposed to be mounted, I got a error and a request to
specify from where I want to boot.
When I typed "?" to see avaliable options, I got the result ( a photo took
from my cell phone):

 I tried several of them including:


Please, could you give some hint about to procedure?

Thanks in advance for your attention


PS.: /dev/ada0 is the actual internal hard disk on the machine wheres I
tried to boot. So, it is not a option

Eduardo Lemos de Sa
Professor Titular
Dep. Quimica da Universidade Federal do Paraná
fone: +55(41)3361-3300
fax:   +55(41)3361-3186

More information about the freebsd-questions mailing list