sshd does not start after upgrade to 11

Waitman Gobble gobble.wa at
Tue Oct 11 03:58:36 UTC 2016

On Sat, Oct 1, 2016 at 6:28 AM, Benjamin Walkenhorst
<walkenhorst.benjamin at> wrote:
> Hello everyone,
> I just upgraded my VPS from 10.3 to 11, and the upgrade *mostly* worked as I had hoped, except that now sshd is not started automatically. Which is kind of annoying for a remote system. ;-)
> When I login through the console and say (as root) „service sshd start“, I get the following output:
> 14:59|root at straylight:/var/log]# service sshd restart
> Performing sanity check on sshd configuration.
> Stopping sshd.
> Performing sanity check on sshd configuration.
> Starting sshd.
> login class '/usr/sbin/sshd' non-existent, using default
> Resource limits for class default:
>   cputime              infinity secs
>   filesize             infinity kB
>   datasize             infinity kB
>   stacksize            infinity kB
>   coredumpsize         infinity kB
>   memoryuse            infinity kB
>   memorylocked               64 kB
>   maxprocesses         infinity
>   openfiles            infinity
>   sbsize               infinity bytes
>   vmemoryuse           infinity kB
>   pseudo-terminals     infinity
>   swapuse              infinity kB
>   kqueues              infinity
>   umtxp                infinity
> Afterwards, „pgrep ssh“ does not show any processes.
> There are no error messages in syslog, either.
> When I run (again, as root) /usr/sbin/sshd manually, it works.
> Did I mess something up during the upgrade inadvertently? Since I can still start sshd manually, I suspect the problem is not with sshd itself, but the way it is started by the init system.
> If anyone could give me a hint on how to proceed, I would be very grateful.
> Kind regards,
> Benjamin
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

The upgrade process of files in /etc is perhaps a bit 'screwy' IMHO. At
minimum it's error-prone. I'm not sure it's common to edit rc.subr

This should fix.

root at fbsf:/etc # mv rc.subr rc.subr.back
root at fbsf:/etc # wget
--2016-10-11 03:50:59--
Resolving (
Connecting to
(||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 48643 (48K) [text/plain]
Saving to: 'rc.subr'

 47.50K  --.-KB/s    in 0.1s

2016-10-11 03:50:59 (418 KB/s) - 'rc.subr' saved [48643/48643]

root at fbsf:/etc # service sshd restart
Performing sanity check on sshd configuration.
sshd not running? (check /var/run/
Performing sanity check on sshd configuration.
Starting sshd.
root at fbsf:/etc #

Waitman Gobble
Los Altos California USA

More information about the freebsd-questions mailing list