sshd does not start after upgrade to 11

Benjamin Walkenhorst walkenhorst.benjamin at
Sat Oct 1 13:28:18 UTC 2016

Hello everyone,

I just upgraded my VPS from 10.3 to 11, and the upgrade *mostly* worked as I had hoped, except that now sshd is not started automatically. Which is kind of annoying for a remote system. ;-)

When I login through the console and say (as root) „service sshd start“, I get the following output:
14:59|root at straylight:/var/log]# service sshd restart
Performing sanity check on sshd configuration.
Stopping sshd.
Performing sanity check on sshd configuration.
Starting sshd.
login class '/usr/sbin/sshd' non-existent, using default
Resource limits for class default:
  cputime              infinity secs
  filesize             infinity kB
  datasize             infinity kB
  stacksize            infinity kB
  coredumpsize         infinity kB
  memoryuse            infinity kB
  memorylocked               64 kB
  maxprocesses         infinity
  openfiles            infinity
  sbsize               infinity bytes
  vmemoryuse           infinity kB
  pseudo-terminals     infinity
  swapuse              infinity kB
  kqueues              infinity
  umtxp                infinity

Afterwards, „pgrep ssh“ does not show any processes. 
There are no error messages in syslog, either.

When I run (again, as root) /usr/sbin/sshd manually, it works.

Did I mess something up during the upgrade inadvertently? Since I can still start sshd manually, I suspect the problem is not with sshd itself, but the way it is started by the init system.

If anyone could give me a hint on how to proceed, I would be very grateful. 
Kind regards,

More information about the freebsd-questions mailing list