Can't upgrade ports, undefined symbol error in Python 2.7 when compiling

Scott Schappell archon at
Mon Oct 10 18:11:24 UTC 2016

I've tried searching, I've tried installing python2.7 from packages instead
of ports, tried various config options for python 2.7 but I can't seem to
figure this on out:

===>  Building for jsoncpp-1.7.7
SCons import failed. Unable to find engine files in:
Traceback (most recent call last):
  File "/usr/local/bin/scons", line 190, in <module>
    import SCons.Script
  File "/usr/local/lib/scons-2.5.0/SCons/Script/", line 77, in
    import SCons.Environment
  File "/usr/local/lib/scons-2.5.0/SCons/", line 55, in
    import SCons.Platform
  File "/usr/local/lib/scons-2.5.0/SCons/Platform/", line 52, in
    import tempfile
  File "/usr/local/lib/python2.7/", line 32, in <module>
    import io as _io
  File "/usr/local/lib/python2.7/", line 51, in <module>
    import _io
ImportError: /usr/local/lib/python2.7/lib-dynload/ Undefined symbol
*** Error code 1

make: stopped in /usr/ports/devel/jsoncpp

I'm somewhat at my wit's end on this one.  I tried reading through
/usr/ports/UPDATING but couldn't readily find anything relevant. Any


More information about the freebsd-questions mailing list