no beep any more

Matthias Apitz guru at
Thu Jul 28 14:25:31 UTC 2016

El día Thursday, July 28, 2016 a las 11:39:24PM +1000, Ian Smith escribió:

> In freebsd-questions Digest, Vol 634, Issue 5, Message: 6
> On Thu, 28 Jul 2016 13:42:39 +0200 Matthias Apitz <guru at> wrote:
>  > El d?a Thursday, July 28, 2016 a las 09:08:10PM +1000, Ian Smith escribi?:
> [..]
>  > >  > I have two of these Acer C720 Chromebooks. One is still beeping and the
>  > >  > other only in the coreboot splash screen, and was beeping in FreeBSD
>  > >  > before. I do not see anything which supports your idea.
>  > > 
>  > > I've been following this thread with interest.
>  > 
>  > Hi Ian,
>  > 
>  > This is nice that you say this, really!

(Ian, btw: your mail server rejects mail from as SPAM)

> I was surprised it was still a mystery .. but I'm still struggling to 
> put a complete picture together re the working / non-working machines, 
> and/or FreeBSD revisions.

here you have a complete picture of the 2 C720 and a Dell E6330:

my C720:

    FreeBSD c720-r292778-amd64 11.0-CURRENT FreeBSD 11.0-CURRENT #0 r292778: Mon Dec 28 05:45:37 CET 2015     root at poudriere-amd64:/usr/local/r292778/obj/usr/local/r292778/src/sys/GENERIC  amd64

    no beep when running 11-CURRENT r292778 from SSD
    no beep when running 12-CURRENT r303343 from USB stick

my son's C720 (a total clone of my C720):

    FreeBSD c720-r292778-amd64 11.0-CURRENT FreeBSD 11.0-CURRENT #2 r292778M: Sun Jul  3 19:33:52 CEST 2016     root at c720-r292778-amd64:/usr/local/r292778/obj/usr/local/r292778/src/sys/GENERIC  amd64

    beeps fine when running 11-CURRENT r292778 from SSD 
    no beep when running 12-CURRENT r303343 from USB stick

Dell Latitude E6330

    FreeBSD e6330-r302904-amd64 12.0-CURRENT FreeBSD 12.0-CURRENT #0 r302904M: Fri Jul 15 22:09:31 CEST 2016     root at e6330-r285885-amd64:/usr/obj/usr/src/sys/GENERIC  amd64

    beeps fine when running 12-CURRENT r302904 from SSD
    no beep when running 12-CURRENT r303343 from USB stick

> And I only just noticed 'only in the coreboot splash screen'; see below.
>  > The problem started some days
>  > ago on the C720 I'm using 7*24 and where I'm typing right now. It could
>  > really be the fact that this C720 has a hardware or BIOS issue. But the
>  > other C720 my son is using, running the same FreeBSD r292778 is beeping
>  > fine but is not beeping when I boot a new USB stick with r303343.
> What's uname -a on r292778?  Since losing access to I 
> can't readily see what's what from just rev numbers.  Maybe not relevant 
> but it sounds like a regression in 11, but there may be other factors ..
>  > That's why I wanted first concentrate on this C720 to learn what the nature
>  > of the issue or configuration is on this and I wrote in the mail from
>  > where you have copied the part b) as well:
>  > 
>  > ...
>  > a) concentrate first on the C720 which still beeps (to eliminate the                                
>  >    risk that the other has a hardware issue)   
>  > > 
>  > > >From a later message from the list archive (not here yet) you say:
>  > > 
>  > >  > b) let away X11, and use as test cases only:
>  > >  >    1. it should beep on key backspace while cursor is on prompt
>  > >  >    2. it should beep on a second ESC in editor vi 
>  > >  >    3. it should beep on the shell command: printf "\7"
>  > > 
>  > > I don't use vi, but 1 and 3 work here fine both from a VT and within 
>  > > KDE, however I have KDE send 'beep' notifications rather than speaker.
>  > > 
>  > > You seem to assume that something's broken in FreeBSD - which may be the 
>  > > case - but it's also possible that the speaker hardware on the non- 
>  > > beeping one is just broken, especially as device speaker didn't work.
>  > 
>  > Yes, from the fact "r292778 beeps, while r303343 does not on the same
>  > hardware and the same BIOS" I think that either there is some config
>  > problem or "a moving target", i.e. some random bug;
> To see if I've got this clear .. it's only with your 11-alpha memstick 
> boot that there's no speaker working?  That applies to both machines?  
> And that both C720s' speakers work right on r292778?

yes they worked both fine until some days;

>  > > Usually the hardware for these in laptops is a simple piezo speaker, 
>  > > commonly with red and blue wires, likely driven by a single TTL or CMOS 
>  > > buffer.  While piezo speakers are pretty hard (but not impossible) to 
>  > > destroy, I've had a laptop where one wire has become detached, so if 
>  > > it's not too hard to get in there to check, that may be worthwhile .. if 
>  > > so it's likely a simple fix, either by soldering or replacement.
>  > > 
>  > > Another possibility is that it's (become?) disabled in BIOS settings?
>  > 
>  > If it comes to the so called BIOS settings, these Chromebooks has no
>  > settings menu. The hardware boots some 'coreboot' software which has as
>  > a payload a SeaBIOS and the only option you have is select the boot
>  > device if there are more than one.
> Ok, thanks.  Hmmm.  But beep works ok at the coreboot boot screen, but 
> not later running under FreeBSD, on one?


> Does it have volume control and mute buttons?  Do these work in FreeBSD? 
> I've seen mention of these in mobile@ and acpi@ but paid no attention ..

They have no special buttons for vol control; this works in KDE with
Alt-F8 (mute) Atl-F9 (lower) and Alt-F10 (vol up) and work fine on both
C720; audio is general is fine on both C720, only PC-speaker is

> Reason I ask is that, just now for old times' sake, I tried the old:
>  # kldload speaker
>  # echo cdefgec >/dev/speaker
> on my Lenovo X200, lid-down accessed via ssh on a 120x50 Konsole.
> Silence.  Huh?  'mixer speaker' shows 70:70.  Backspace at prompt, KDE 
> beeptone.  Surprised, I (cleared then :) opened the lid and logged in; 
> no backspace beep.  Oh, ah - hit volume-up .. beep all good,  Hit mute, 
> beep gone locally - but Konsole remotely still does its KDE notify beep 
> as mentioned, so I hadn't noticed it had been muted for maybe a week ..
> Which is a longwinded way of saying: try eg the volume-up button while 
> at coreboot screen, in case if booted in 'mute' state, freebsd won't be 
> able to unset that, especially if volume buttons don't work in freebas?
> Just a long shot .. no warranty ..
>  > So, back to the above question: why the beast is beeping with r292778
>  > and not with r303343? Maybe the answer to this will later explain why
>  > the other C720 is not beeping at all at the moment, not with r292778 and
>  > not with r303343...
> Now the last bit is why I was (re)confused .. you mean the was-working 
> one has become non-working since trying 11-alpha2, even back on r292778?

No. Both run r292778 for some months and beeped fine. One stopped
beeping, while audio is still fine;

>  > In any case I will open my C720 and look for the red/blue wires, if they
>  > are not below the motherboard :-(
> No, if the other one has 'gone bad' too, it almost must be software.  Or 
> firmware.  Apart from the mute button thing, you could try a real cold 
> reset (ie battery removed and replaced after a time).  Out of ideas ..
> cheers, Ian  (Please cc me, digests can take a full day sometimes)

I Cc you but it bounces.


Matthias Apitz, ✉ guru at, ⌂  ☎ +49-176-38902045
"Wer übersieht, dass wir uns den anderen weggenommen haben und sie uns wiederhaben wollen,
kann von den Kämpfen der letzten Tage keinen verstehen. Und kann natürlich auch keinen
dieser Kämpfe bestehen." Hermann Kant in jW 1.10.1989

More information about the freebsd-questions mailing list