"fsck -y /" keeps saying "Disk is still dirty" no matter how many times I run it

Lars Eighner luvbeastie at larseighner.com
Sat Jan 9 00:17:40 UTC 2016

On Fri, 8 Jan 2016, Yuri wrote:

> As a result of the power outage I needed to run fsck on UFS disk with 
> soft-updates.
> But every time the command 'fsck -y /' says that it corrected a lot of 
> problems, but it still leaves the disk dirty. I ran it at least 15 times - 
> same result.

Most likely you have a bad sector on your disk. fsck cannot fix this. When 
you write to the disk, hopefully the disk will mark the sector bad, and 
basically hide it. Unfortunately, you cannot mount it to write if it is 
dirty. You can only newfs it, which means goodbye to everything since your 
last backup. After you newfs, you can restore from your backup.

> What would be the way to proceed from here?
> (I ran fsck before, but it never happened that fsck keeps finding problems)
> Thank you,
> Yuri
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

Lars Eighner
8800 N IH35 APT 1191 AUSTIN TX 78753-5266

More information about the freebsd-questions mailing list