rxvt question

William A. Mahaffey III wam at hiwaay.net
Thu Feb 4 20:56:07 UTC 2016

I have been using rxvt w/ XFCE under FreeBSD 9.3R for CLI tasks on my 
daily-driver desktop for about 18 mos. now, love it. Since I use this 
box for web access as well as LAN access to other boxen on my LAN, it 
doesn't get refreshed very often, since I like the continuity of being 
able to return to tasks by just clicking back to the window I was 
working in earlier. I always have 4 desktops, with about a dozen RXVT 
shells each open in 2 of the desktops, sometimes a few more, usually a 
few xterms as well. The other 2 desktops are used for GUI stuff, 
browsers, e-mail client, etc.

I did a full system upgrade this A.M. (freebsd-update + 'pkg upgrade 
-y') & rebooted & logged back in. I have noticed over the last few 
months that whenever I log out & back in, most of the RXVT windows are 
re-opened as they were when I logged out, fonts OK, text rendered OK, 
etc., but some are recreated in an oddball state such that when I open 
them up to full screen size, they still render text in only about 70 
columns, rather than full 132-ish. I usually just shut those windows & 
open new ones, since I always use them 'full screen'. This A.M., when I 
clicked on the 'RXVT shell' button on my desktop lower menu, nothing 
happened. I tried from the CLI of another open shell & same story:

[wam at kabini1, ~, 10:17:07am] 301 % hrxvt
    107  9:00    ( rxvt -sl 5000 -fn 
-*-lucidatypewriter-bold-r-normal-sans-17-*-100-100-*-100-*-* & )
    108  9:00    ( rxvt -rv & )
    109  9:00    rxvt -sl 5000 -title "System Terminal" -fg red -bg 
darkred -e su -l root
    110  9:00    rxvt -sl 5000 -title "System Terminal" -fg red -bg 
black -e su -l root
    301  10:18   hrxvt
[wam at kabini1, ~, 10:18:35am] 302 % !107
( rxvt -sl 5000 -fn 
-*-lucidatypewriter-bold-r-normal-sans-17-*-100-100-*-100-*-* & )
[wam at kabini1, ~, 10:18:43am] 303 % rxvt: No match.

[wam at kabini1, ~, 10:18:46am] 303 %
[wam at kabini1, ~, 10:18:46am] 303 %
[wam at kabini1, ~, 10:18:46am] 303 % which rxvt
[wam at kabini1, ~, 10:18:51am] 304 % ( /usr/local/bin/rxvt -sl 5000 -fn 
-*-lucidatypewriter-bold-r-normal-sans-17-*-100-100-*-100-*-* & )
[wam at kabini1, ~, 10:19:06am] 305 % /usr/local/bin/rxvt: No match.

[wam at kabini1, ~, 10:19:07am] 305 %
[wam at kabini1, ~, 10:19:07am] 305 %
[wam at kabini1, ~, 10:19:08am] 305 %

These lines were typed in *after* I tried the menu button on my XFCE 
desktop. I only log out & back in as needed, often many weeks or months 
between logins, so I am not sure exactly when this might have started :-/.

[wam at kabini1, ~, 10:19:08am] 305 % uname -a
FreeBSD kabini1.local 9.3-RELEASE-p33 FreeBSD 9.3-RELEASE-p33 #0: Wed 
Jan 13 17:55:39 UTC 2016 
root at amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
[wam at kabini1, ~, 2:50:46pm] 306 %

rxvt-2.6.4_6, xfce-4.12_1, everything fresh as of this A.M. Is rxvt 
still actively maintained ? Known/thought to work OK w/ XFCE ? Any other 
issues/gotchas ? Pilot error ? Any clues appreciated, any info needed 
just ask. TIA & have a good one.


	William A. Mahaffey III


	"The M1 Garand is without doubt the finest implement of war
	 ever devised by man."
                            -- Gen. George S. Patton Jr.

More information about the freebsd-questions mailing list