zfs (zxfer) replication -- "holes" in backups?

Brandon J. Wandersee brandon.wandersee at gmail.com
Wed Dec 21 01:41:44 UTC 2016

Malcolm Matalka writes:

> Aleksandr Miroslav <alexmiroslav at gmail.com> writes:

>> It turns out that when I sent my snapshots to my backup machine, I never
>> turned off this property, the backup machine also had zfstools installed,
>> and so was taking snapshots of my backupsnaphots. Hence the holes. I've
>> since cleaned this up, and will let backups run for a few days and see if
>> this fixes the problem.
> I ran into this problem where the snapshots the machine that was backing
> up to named the snapshots the same thing so zxfer thought the transfer
> didn't need to happen.  I "solved" this by putting the hostname in the
> snapshot name.  There is probably a better way though.

I'm not sure there's an entirely elegant way to deal with it. I use
zfstools and zxfer myself, and have just accepted having a really long
line in the crontab to remove the properties before transfer.

I used to use sysutils/zfsnap, which is a pretty good tool in its own
right and can avoid the problem of the system holding backups creating
new snapshots on the backups. However, it does that by requiring
multi-entries for each type of backup iteration, as well as lines for
every single dataset, added to /etc/periodic.conf. Works well enough for
simple setups, but more complex ones get out of hand.

::  Brandon J. Wandersee
::  brandon.wandersee at gmail.com
::  --------------------------------------------------
::  'The best design is as little design as possible.'
::  --- Dieter Rams ----------------------------------

More information about the freebsd-questions mailing list