zfs (zxfer) replication -- "holes" in backups?

Malcolm Matalka mmatalka at gmail.com
Tue Dec 20 12:36:57 UTC 2016

Aleksandr Miroslav <alexmiroslav at gmail.com> writes:

> On Fri, Dec 16, 2016 at 5:08 PM, Aleksandr Miroslav <alexmiroslav at gmail.com>
> wrote:
>> I'm using a pkg called zfstools to take my snapshots. It takes snapshots
>> called frequent, hourly, daily, weekly, and monthly.
> The problem may have been even more sillier. The snapshots taken by the
> package zfstools depends on this property:
> $ zfs get all zroot/usr/home|grep auto-snapshot
> zroot/usr/home  com.sun:auto-snapshot  true                   local
> It turns out that when I sent my snapshots to my backup machine, I never
> turned off this property, the backup machine also had zfstools installed,
> and so was taking snapshots of my backupsnaphots. Hence the holes. I've
> since cleaned this up, and will let backups run for a few days and see if
> this fixes the problem.

I ran into this problem where the snapshots the machine that was backing
up to named the snapshots the same thing so zxfer thought the transfer
didn't need to happen.  I "solved" this by putting the hostname in the
snapshot name.  There is probably a better way though.

> Alex
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list