multimedia/quodlibet fails to build on AMD64

Ben Woods woodsb02 at
Wed Aug 24 13:04:35 UTC 2016

On 22 August 2016 at 06:56, eteep <eteepfiles at> wrote:

> Hello,
> I tried searching for previous occurrences of the issue but found
> nothing so far. It is with the port multimedia/quodlibet. It fails build
> but I'm not so much more than an ordinary schuck and it doesn't clearly
> indicate what is up(to me anyway). Looks like it is an issue relating to
> python and it
> looks like I have both python 27 and 34 installed. I've had to resolve
> version conflicts before in ports and it has occurred to me there might
> be one here and yet the port py27-six-1.10.0 seems to indicate thats not
> the case.
> So rather than spinning my wheels on this I figured I would post to see
> if more experienced eyes can see what I can't.

Hi eteep,

I was the last person to make a change to the audio/quodlibet port, but I
cannot repeat your error.

I assume it must be something to do with building the port in an
environment which has both python 2 and python 3 installed. Have you tried
building it in a "clean" environment (e.g. using poudriere)?

Anyone else know what this error means?

File "gdist/", line 42, in update_pot
    raise GettextError(e)
gdist.gettextutil.GettextError: Command '['intltool-update', '--pot',
'--gettext-package', 'quodlibet']' returned non-zero exit status 1
*** Error code 1


More information about the freebsd-questions mailing list