How to access CUPS printer from wine applications ?

Manish Jain bourne.identity at
Wed Apr 27 04:41:29 UTC 2016

On 04/27/16 03:39, Polytropon wrote:
> On Tue, 26 Apr 2016 23:32:45 +0530, Manish Jain wrote:
>>> Wine can be built with CUPS support but it isn't enabled by default so
>>> you have to build your own package:
>>> cd /usr/ports/emulators/wine
>>> make config
>>> (enable the CUPS option)
>>> make install clean
>> Hi Tijl,
>> Ah, I am on amd64, so I have to use i386-wine, not wine. The CUPS option
>> applies only to the wine port, not i386-wine - which can only be built
>> with MONO/GECKO options.
> I have just checked this interesting solution on the i386 version.
> I ran "wine wordpad", typed some nonsense, and hit Ctrl+P. The
> printers known to CUPS did show up in the printer dialog, and
> when the job was submitted, it appeared in the correct queue
> (and got printed as intended). Well, I never tried that, but who
> knows where it might be useful... :-)

No, I just get a modal dialog stating that no printers are installed. 
"Please install one and retry".

More information about the freebsd-questions mailing list