Poudriere and apache24 with http2 module enabled fails

Herbert J. Skuhra herbert at oslo.ath.cx
Tue Nov 3 10:08:20 UTC 2015

On Mon, Nov 02, 2015 at 08:27:53AM +0100, Matthias Fechner wrote:
> Dear all,
> I installed apache24 (2.4.17) using ports with the new http2 module
> enabled and it builds fine and runs fine.
> I tried now to create a package with poudriere but it fails with the
> error message:
> checking for nghttp2 version >= 1.0.0... FAILED
> configure: WARNING: nghttp2 version is too old
> no
> checking whether to enable mod_http2... configure: error: mod_http2 has
> been requested but can not be built due to prerequisite failures
> The full log can be found here:
> http://pkg.fechner.net/logs/bulk/102amd64-default/latest/logs/errors/apache24-2.4.17.log
> I already tried it with different make.conf definitions but it seems
> that the configure script thinks that the installed nghttp2 (1.4.0) is
> older than 1.0.0.
> Was anyone successfull to build a apache24 package using poudriere with
> http2 module enabled?

Have you checked


for more details?


More information about the freebsd-questions mailing list