Poudriere and apache24 with http2 module enabled fails

Matthias Fechner idefix at fechner.net
Mon Nov 2 07:28:09 UTC 2015

Dear all,

I installed apache24 (2.4.17) using ports with the new http2 module
enabled and it builds fine and runs fine.
I tried now to create a package with poudriere but it fails with the
error message:
checking for nghttp2 version >= 1.0.0... FAILED
configure: WARNING: nghttp2 version is too old
checking whether to enable mod_http2... configure: error: mod_http2 has
been requested but can not be built due to prerequisite failures

The full log can be found here:

I already tried it with different make.conf definitions but it seems
that the configure script thinks that the installed nghttp2 (1.4.0) is
older than 1.0.0.

Was anyone successfull to build a apache24 package using poudriere with
http2 module enabled?



"Programming today is a race between software engineers striving to
build bigger and better idiot-proof programs, and the universe trying to
produce bigger and better idiots. So far, the universe is winning." --
Rich Cook

More information about the freebsd-questions mailing list