System Compile Failure

Olivier Nicole olivier.nicole at
Fri Mar 27 17:27:37 UTC 2015


> I am having trouble compiling the system and kernel for 10.1-RELEASE
> on my server.  It exits with a failure on the base compilation and
> kernel.

I had the same problem yesterday.

I tried to delete /usr/obj before make buildworld, then I tried to
delete /usr/src and svn a new copy of the system and it worked.


> As a solution I compiled everything on another system then tarball the
> whole src tree.  However, when I go to install the kernel  via #make
> installkernel, it complains that no kernel has been compiled (even
> though it was before I changed systems).  Now the only thing that
> comes to mind is that this is an AMD64 system.  Maybe the install
> scripts know this and want to install a customized kernel for AMD64.
> However, I only compiled the generic kernel.  However, that is what is
> running the system now, an i386 generic kernel.
> I prefer src installs because of the mergemaster stages.  I like how
> quickly I can merge files with it.
> I have found an article about converting a system to AMD64, but it was
> a bit on the old side.  I am not sure if it was still relevant.  It
> was written circa 9.0.
> Appreciate the help, I spent about six hours trying my own little
> fixes to no avail.
> Regards,
> Chris Maness
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list