ZFS passdevgonecb

Da Rock freebsd-questions at herveybayaustralia.com.au
Wed Jun 17 12:35:43 UTC 2015

On 16/06/2015 19:15, Fabian Keil wrote:
> Da Rock <freebsd-questions at herveybayaustralia.com.au> wrote:
>> I hate jumping in like this out of the blue, but time is not on my side
>> atm with a lot going on.
>> I have a problem with some devices disappearing on various versions of
>> FreeBSD and machines (laptops, workstations/servers). Umass are the
>> norm, with the message occurring most on usb sticks and sd cards.
>> Big problem atm is that my file server has a failed disk in the raid,
>> and I've tried replacing it with a new drive (twice now), and both times
>> it begins to resilver and then it is "REMOVED". If I online it again, it
>> goes for about 10mins then REMOVED again.
> For similar occasions I wrote a ggatel patch as a workaround:
> https://www.fabiankeil.de/sourcecode/electrobsd/ggatel-Optionally-retry-requests.diff
> Later on I stumbled over gmountver which you may want to try
> first. At least on my system it doesn't work unless I disable
> kern.geom.mountver.check_ident (which obviously is dangerous),
> but I didn't have time to investigate this yet.
That appears to be a patch for usb base though, right? I have had issues 
with usb and sd cards, but this one is actually an ada device (hdd).

Also I couldn't find kern.geom.mountver at all - unknown oid. What are 
you using? Is that a device specific?
>> Dmesg shows that the device is removed from the devfs with a
>> passdevgonecb/lost device message. This apparently occurs right at boot
>> too, as it shows amongst the usual scrolling during boot.
>> I had a chat with someone and they mentioned the cable and/or controller
>> could be the issue. Could anyone add any insight or tests I could do?
> Scrubbing the pool with one of the workarounds mentioned above might
> be a good start.
Scrub is ok, but still no device in the raid - REMOVED.

Thanks for the help, but so far still no go.

More information about the freebsd-questions mailing list