FreeBSD 10.1, Mac Pro 2008, EFI, hangs at boot w/ "Start @0xfff...."

Andreas Wrede aew.freebsd at
Sat Jun 13 15:00:16 UTC 2015

> On Jun 12, 2015, at 21:47 , George Hartzell <hartzell at> wrote:
> I have a 2008 Mac Pro (NOT a MacBook) that's been happily running
> FreeBSD for years via MBR partitioned disks.  When the Mac sees the
> MBR partition it kicks in a bunch of bios emulation, which lets
> freebsd run.
> I've recently been inspired to try the EFI booting stuff.  It has the
> attraction of enabling the two extra SATA ports on the motherboard (or
> more accurately, not disabling them as the BIOS emulation appears
> to...).
> I've tried both a USB stick of 10.1 and an SSD with -CURRENT.  Both
> use EFI booting and work on my Minnowboard.
> Booting either way exhibits the same symptom.  /boot/loader.efi
> runskoads the kernel and stuff but when it boots it prints
>    Booting...
>    Start @0xffffffff802e7000 ...
>    _
> (that's the address when booted from the SSD, the address for the 10.1
> USB stick is 0xffffffff802df060)
> and then hangs.
> Thinking that maybe the console was pointing off somewhere, I tried
> setting it at the forth/OK prompt, it was already set to "efi", which
> seems like the best choice.
> It'd be nice to get it booting via EFI.  Any suggestions for what to
> try next?

My experience with a Mac Pro (2009) is similar. I tried to boot from CD and USB with FreeBSD 10.1 and a -current snapshot from about 2 weeks ago. A MacBook Pro (2010) booted without a problem with the both the 10.1 and -current USB images.  The MacPro will be available for more testing in a week or two.


More information about the freebsd-questions mailing list