Ulpt problems.

Bernt Hansson bah at bananmonarki.se
Sun Jul 26 14:19:53 UTC 2015

On 2015-07-25 18:42, Ramiro Caso wrote:
> Here's how far I got (I have a working printer without ulpt and with 
> cups).
> On 24/07/2015 07:48, Bernt Hansson wrote:
>> On 2015-07-24 05:37, Warren Block wrote:
>>> On Fri, 24 Jul 2015, Bernt Hansson wrote:
>>>> It seems that one needs ulpt, otherwise the printer isn't found.
>>>> So I added to /boot/loader.conf ulpt_load="YES" then the printer is 
>>>> found by cups and hplip.
> In order to use a printer with cups and ugen instead of ulpt, you have 
> to put some rules in devfs.rules, something like:
> add path 'usb*' mode 0770 group cups
> add path 'ugen*' mode 0660 group cups
> add path 'usb/4.3.*' mode 0660 group cups
> Where 4.3 is where the printer appears (just running usbconfig tells 
> you where that is). Maybe the rules are redundant, I don't recall 
> anymore, but again it worked for me. These rules give cups access to 
> the printer device.
I've done that, nothing happens.

>>>> But I do not want to use cups so I deinstalled it. Cups can't print 
>>>> a testpage so I resorted to lpd.
>>>> Which can't print anything, so back to cups that too can't print 
>>>> anything. So I'm stuck.
>>> The ulpt module is loaded by /etc/devd/usb.conf.  The file says 
>>> "please do not edit", and I don't know how those modules are disabled.
> You have to create a configuration file for devd under /usr/local/etc. 
> What I did is to copy the entries in usb.conf that load the ulpt 
> module into this new file, change the priority to something higher 
> than 32, and change the action from "kldload -n ulpt" to a trivial 
> action, "true". I think there is a better, non hackish thing to do, 
> but it worked for me.
Done that too. Nothing.

>>>> Printer is HP laserjet P2055d
>>> That printer supports PostScript directly, so following the LPD 
>>> setup in the Handbook is the easiest course.  Deinstall CUPS first, 
>>> because it has not-quite-compatible commands with the same names as 
>>> the real ones.
>>> If the printer has a network interface, that is the preferred 
>>> connection.  But USB will work, too.
>> Now that it finds the printer it's not printing anything with cups or 
>> lpd.
>> I'm using apsfilter and lpd. Hplip is deinstalled so is cups. But no 
>> cigar.

More information about the freebsd-questions mailing list