mis-match library in 10.1 octave/g++48 package
jguojun at sbcglobal.net
Fri Apr 3 06:55:53 UTC 2015
Okay, switched to 8.4-R and replaced /usr/lib/libstdc++.so.6 from package gcc-4.6.3, the problem solved.
But still has no clue how to solve the /lib/libgcc_s.so.1 problem for 10.1-R system.
On Thursday, April 2, 2015 9:34 PM, Jin Guojun <jguojun at sbcglobal.net> wrote:
It looks like that libstdc++.so.6 is too old, which does not support GLIB 3.4.10 or later.
libstdc++.so.6 is part of system installation, not a package.
Question is if installing a latest libstdc++.so, will it break the current system?
/libexec/ld-elf.so.1: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.15 required by /usr/local/lib/octave/3.6.3/liboctave.so.2 not found
%strings /usr/lib/libstdc++.so.6 | grep GLIB
On Thursday, April 2, 2015 2:50 AM, Bernt Hansson <bah at bananmonarki.se> wrote:
There is a PR for this error
On 2015-04-02 09:08, Jin Guojun wrote:
> I installed octave-3.8.2 and compiled code but got run time error as following:
> g++48 octave-c-api.c -I/usr/local/include/octave-3.8.2/octave -I/usr/local/include -L/usr/local/lib/octave/3.8.2 -loctave -lpcre
> /lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc48/libgfortran.so.3 not found
> GNU C library often cause such problem, but it is not clear why gcc 4.8 requires 4.6 library.Does anyone know how to solve this problem?
> Current octave package requires gnu c++ (g++) to build, and native BSD c++ does not work on this build.I wonder if octave can be built by BSD C/C++ compiler instead of G++ to avoid such problem in future.
> Also, since 10.1-R use pkg to fetch/install packages from a centralized repository, and package is keeping to update to the latest release, some mechanism needs to be used to insure the library will match.
More information about the freebsd-questions