dockbook.xsl -- can't load when building port

Gary Aitken vagabond at
Sat May 17 20:34:15 UTC 2014

>> Trying to rebuild ports after pkg delete -a
>> Lots of stuff fails with things like:
>> /usr/local/bin/xmlto man dbus-monitor.1.xml
>> compilation error: file /tmp/xmlto-xsl0Tylm9 line 4 element import
>> xsl:import: unable to load
>> ""
>> I/O Error: Attempt to load network entity
>> ""
>> I have turned off language options in most packages,
>> but have left docs included in all of them
>> executing the above xmlto cmd generates the error outside of all build
>> scripts;
>> I can go to the above url and load it fine.
>> what's the magic I need?
>> 9.2-RELEASE, amd64
> Try to the follow the instructions from /usr/ports/UPDATING:
> 20140219:
>   AFFECTS: users of textproc/docbook*
>   The textproc/docbook-* ports have been consolidated into two ports
>   textproc/docbook-sgml and textproc/docbook-xml.

Hmmm, interesting.
I had four docbook things already installed:

I copied a docbook.xsl into /usr/local/share/xmlto
and tried rebuilding devel/dbus but that didn't change anything.

I then reinstalled the four docbook ports listed above and somehow that
fixed it.
The "only" thing different is docbook.xsl was still in
/usr/local/share/xmlto when I rebuilt.

Anyway, thanks.

More information about the freebsd-questions mailing list