UEFI boot on 10.0 STABLE?

Arthur Chance freebsd at qeng-ho.org
Wed Jul 23 14:32:40 UTC 2014

On 22/07/2014 19:48, David Benfell wrote:
> Hi all,
> The way I'm booting into FreeBSD right now is far from ideal. For what
> it's worth, this is an Asus X202e notebook.
> What I'm doing now is using a Debian kFreeBSD disk to get to grub. It
> has an option to boot from the first hard disk. That's literally all I
> need to boot FreeBSD. I'm presently using legacy BIOS emulation to boot
> the kFreeBSD disk but its a GPT disk.
> I also needed legacy mode to boot the FreeBSD installation disk so I
> could even install FreeBSD.
> I did create an additional EFI partition at the beginning of the disk,
> modifying the default install.
> What I'm seeing now looks kind of like a chicken-and-egg problem. I
> tried installing grub-efi-amd64 but it fails to work the appropriate
> magic and cast the appropriate spell. I suspect because the disk is GPT
> running under legacy mode.
> I also tried rEFInd which has helped enormously with previous linux
> installations. No joy this time.
> I've now blown both grub-efi and rEFInd away on the theory that I need
> to start fresh.
> It looks like code to deal with UEFI has been merged in to HEAD (a
> statement that doesn't actually mean all that much to me) and I *am* at
> this moment trying to upgrade from 10.0 RELEASE to STABLE. Is needed
> code in STABLE (and not in RELEASE)?
> Has anyone found a path through this? Where/what is it? Should I just
> wait for 10.1?

I've just spent an hour or two looking through the UEFI relevant bits of 
the svn repository as I've acquired a new box with UEFI. As you say, the 
UEFI boot code has been merged in HEAD. HEAD is another way to refer to 
FreeBSD-CURRENT, which the Handbook describes as

 > FreeBSD-CURRENT is the “bleeding edge” of FreeBSD development and
 > FreeBSD-CURRENT users are expected to have a high degree of technical
 > skill. Less technical users who wish to track a development branch
 > should track FreeBSD-STABLE instead.

aka "here be dragons".

As far as I can see, UEFI booting has not yet been merged into 
10-STABLE, so no luck there. However various people have reported on 
both the mailing lists and the forums that legacy booting works for 
10.0. The gotcha for Asus kit appears to be the fact that if you've got 
a GPT formatted disk, you have to set the active flag on the protective 
MBR in order to get legacy booting working. MBR formatted disks just 
work. Take a look at this forum thread for more information


As for whether 10.1 will have UEFI booting, that's way over my pay 
grade, but I hope it does. I've not found anything about what 10.1 will 
contain yet, and it's at least 4 months off.


More information about the freebsd-questions mailing list