UEFI boot on 10.0 STABLE?

David Benfell benfell at parts-unknown.org
Tue Jul 22 18:49:03 UTC 2014

Hi all,

The way I'm booting into FreeBSD right now is far from ideal. For what it's  
worth, this is an Asus X202e notebook.

What I'm doing now is using a Debian kFreeBSD disk to get to grub. It has  
an option to boot from the first hard disk. That's literally all I need to  
boot FreeBSD. I'm presently using legacy BIOS emulation to boot the  
kFreeBSD disk but its a GPT disk.

I also needed legacy mode to boot the FreeBSD installation disk so I could  
even install FreeBSD.

I did create an additional EFI partition at the beginning of the disk,  
modifying the default install.

What I'm seeing now looks kind of like a chicken-and-egg problem. I tried  
installing grub-efi-amd64 but it fails to work the appropriate magic and  
cast the appropriate spell. I suspect because the disk is GPT running under  
legacy mode.

I also tried rEFInd which has helped enormously with previous linux  
installations. No joy this time.

I've now blown both grub-efi and rEFInd away on the theory that I need to  
start fresh.

It looks like code to deal with UEFI has been merged in to HEAD (a  
statement that doesn't actually mean all that much to me) and I *am* at  
this moment trying to upgrade from 10.0 RELEASE to STABLE. Is needed code  
in STABLE (and not in RELEASE)?

Has anyone found a path through this? Where/what is it? Should I just wait  
for 10.1?


David Benfell
See https://parts-unknown.org/node/2 if you do not understand the  
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 811 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20140722/cee5eef9/attachment.sig>

More information about the freebsd-questions mailing list