All of a sudden, problems with X

Polytropon freebsd at
Tue Jul 22 03:14:33 UTC 2014

On Mon, 21 Jul 2014 19:46:43 -0700, David Benfell wrote:
> Now I've rebooted and I can't get Xorg working properly at all.

Did you perform any updates?

> Xorg -configure yields only a black (apparently not blank) screen. I
> tried adding the magic to allow CTRL/ALT/BACKSPACE but it doesn't
> work (yes, I rebooted after adding the magic).

There currently are two magics for that: The "magic in xorg.conf"
when using X without HAL, and the "magic with XML" involving the
configuration files scattered across /usr/local/ when using HAL.
Do you use X with or without HAL? If with, is everything running?

> The only way out of the
> black screen is CTRL/ALT/DEL, which reboots the system.

This key combination usually does _nothing_ when within X, so if
it works, it seems to suggest that you have exited X, you're back
at the text mode console, but you can't see it (blank screen).

> If I use startx, I get a correct display, but the mouse doesn't work.

Often a problem related to HAL. Make sure you exactly follow the
handbook in getting the input working. In case you have updated X,
also update its "input" components.

> I actually have two of them. This is a notebook system, so one is the
> touchpad and the second is a Kensington trackball.

The touchpad is probably represented as a PS/2 mouse (check "dmesg"
output for "psm0"), and I assume the trackball is connected to USB,
so it should be detected automatically.

> psm0: <PS/2 Mouse> irq 12 on atkbdc0
> psm0: [GIANT-LOCKED]
> psm0: model Generic PS/2 mouse, device ID 0

This probably is your laptop's glidepad.

> ums0: <Kensington Kensington Expert Mouse, class 0/0, rev 1.10/1.00, addr 5> on usbus0
> ums0: 4 buttons and [XYZ] coordinates ID=0

And this is the trackball.

>From the X log, those are disappointing:

> [   544.688] (**) ModulePath set to "/usr/local/lib/xorg/modules"
> [   544.688] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
> [   544.688] (WW) Disabling Mouse0
> [   544.688] (WW) Disabling Keyboard0
> [   546.330] 
> [   546.330] 
> Xorg detected your mouse at device /dev/sysmouse.
> Please check your config if the mouse is still not
> operational, as by default Xorg tries to autodetect
> the protocol.
> [   546.330] 

Again, check with the handbook's section about X configuration.
You probably have a problem with HAL. Many people seem to have. :-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list