Long delays in 'pkg upgrade' and other mysteries ..

Adrian Chadd adrian at freebsd.org
Tue Jul 15 14:50:55 UTC 2014

Ugh, so, there's a bunch of conflicts with package renames. You have
to read /usr/ports/UPDATING to get the full list of what to modify.

I haven't had this happen in months. The ports metadata side of things
has gotten a lot better over the last year - you're just experiencing
the handful of rounds of "incomplete metadata" and "wanton package
renaming" hilarity that marred the whole binary package experience.

(It got better. :-)


On 15 July 2014 07:26, Ian Smith <smithi at nimnet.asn.au> wrote:
> Dear Hive,
> On 9.3-PRE world June 26th, I converted the 700-odd packages originally
> installed from the 9.2-R dvd1_memstick, plus a handful subsequently, to
> pkgng three days ago.  That seemed to go smoothly, and didn't take long.
> So today I ran 'pkg update' to sync it up, then 'pkg upgrade' to upgrade
> all packages.  That was almost 4 hrs ago and ever since I've watched it
> fetch 657 packages to /var/cache/pkg/All, one about every 16-17 seconds,
> doing apparently nothing meanwhile.
> I'm getting 3-400KB/s on small packages, taking one or two seconds each,
> and 5-700KB/s on larger ones.  Then it sits, top showing pkg in kqwait
> for around 15-17 seconds, gkrellm the busiest thing running at 2-3%, few
> percent for Xorg, KDE etc - basically idle - until (what looks like) a
> sleep expires, pkg springs into action for maybe a second doing the next
> fetch, then it goes back to sleep.  Why would this be?
> During that ~4 hours the sqlite db was locked, I couldn't 'pkg info' to
> see where it was up to, or 'pkg which' to hunt down a lost link related
> to an earlier unsuccessful 'portmaster --packages www/firefox' run which
> may have screwed things up, after which I thought upgrading all packages
> the best idea, and certainly worth a try to gain confidence with pkg :)
> But no; after fetching ~900MB to cache, it spewed a large number (eg):
> pkg: WARNING: locally installed docbook-5.0_1 conflicts on
> /usr/local/share/xml/docbook/5.0/xsd/xml.xsd with: - docbook-xml-5.0_2
> After that, the last 'pkg: WARNING:' line above .. nothing.  Not a word.
> Just the prompt.  Too many errors?  No apparent changes to any pkgs nor
> the database, though the earlier portmaster shows some installed.
> That was the last of > 2000 lines of these msgs, for installed packages
> qt4-*-4.84, perl5.14-5.14.4_7 and docbook-5.0_1 mostly, but I lost lots
> off the top; python27-2.7.6_4 came up too.  I suspect portmaster earlier
> managed to update these, but not register them?
> Ah yes, later, perhaps I see; I should have upgraded portmaster before
> using it, the older one was doing an all-source upgrade :(  And likely
> trying to register upgrades using the old package_tools too .. there
> still be a few dragons afoot ..
> Later; I ran a second 'pkg upgrade' inside script(1), so if anyone might
> benefit from seeing a 170KB list of conflicts, just ask.
> So what should I do now, short of starting from scratch?
> cheers, Ian  (please cc me)
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list