Unable to boot on USB key on Lenovo Thinkpad T440

Kata Goto black.katagoto at gmail.com
Tue Jan 28 01:17:05 UTC 2014

2014-01-25 Warren Block <wblock at wonkity.com>

> On Fri, 24 Jan 2014, Kata Goto wrote:
>  Hello all,
>> I recently (this week), recieved a Lenovo Thinkpad T440 and I want to
>> install FreeBSD, so I have disabled the secure boot and force the legacy
>> boot mode only.
>> Then I have downloaded an USB image and write it via
>>    $ dd if=FreeBSD-9.2-RELEASE-amd64-memstick.img of=/dev/da0 bs=64k
>> (I also tried with 10.0-RELEASE)
>> And my laptop refuses to boot on it, even if I force to boot on it (via
>> <F12>).
>> My USB key works well on other computers (they boot on it) and my laptop
>> boots well on an Ubuntu USB key.
>> I have also tried to boot on an external CD Drive, but nothing change :/
>> I am running out of ideas.
>> If you have the same issue or new ideas, please, let me know.
> The USB image uses a bare BSDlabel, aka "dangerously dedicated", meaning
> there is no MBR at all.  Some versions of Thinkpad firmware had strange
> misconceptions about disk formats.  A CD could boot fine, being a more
> common format.  Make certain the Thinkpad firmware is the latest version,
> and the USB image might work.
> Some work with gpart and dd might be able to convert the USB image to an
> MBR/BSDlabel format which would boot.
> Or the problem might not be related to the bare BSDlabel, but that it
> works on everything but the Thinkpad make it a good guess.


In fact I have to enable the UEFI USB Boot setting :/

Thanks for all.

More information about the freebsd-questions mailing list