fail2ban errors on start

David Noel david.i.noel at
Sat Feb 15 20:36:05 UTC 2014

I've been having some trouble with fail2ban this afternoon. After
installation, /usr/local/etc/rc.d/fail2ban start gave me "ERROR There
is no directory /var/run/fail2ban to contain the socket file
/var/run/fail2ban/fail2ban.sock". After some searching for answers and
finding no information that seemed relevant I wound up just trying
"mkdir /var/run/fail2ban" and that got me past the error. But now I'm
encountering another error on startup: "ERROR Could not start server.
Maybe an old socket file is still present. Try to remove
/var/run/fail2ban/fail2ban.sock. If you used fail2ban-client to start
the server, adding the -x option will do it". I've tried what it's
suggested, scanned the docs, searched for solutions, tried different
methods of starting fail2ban, but haven't found anything that has
helped. Has anyone run into this before? How did you manage to get
around it?

More information about the freebsd-questions mailing list