FreeBSD on Macbook Pro early 2011

Fred wade-is-great at
Sun Aug 17 00:02:40 UTC 2014

Hi everyone!

I am trying to install FreeBSD on my Macbook pro early 2011 in dual boot with OS X Mavericks but so far I could not boot on it once the installation is complete.

Computer specs:

I tried using the gpart command, blessing the partition, using gdisk to create an hybrid MBR, but so far nothing has worked.

Here's what I tried:
I also looked in the mailing lists, and the FreeBSD forums, but I could not find any solutions.

Now on latest versions of OS X Bootcamp (Mountain Lion, Mavericks) I cannot create a partition without having a Windows disk, and I also tried using Bootcamp under Snow Leopard.

Regarding the errors I have after the installation, it's either "can't load kernel" or "Missing bootloader", with or without hybrid MBR. The partition table is GPT, and the system uses a EFI boot manager.

Thanks in advance for any answer to my problem.


More information about the freebsd-questions mailing list