Port of icedtea-web-1.4_1, on 64 bit system might have a problem in the install process.

dweimer dweimer at dweimer.net
Tue Oct 1 18:12:27 UTC 2013

On 10/01/2013 11:09 am, dweimer wrote:
> I was struggling to get itweb-javaws to execute, due to it not being
> able to find libjava.so, after running it through truss, I was able to
> determine that its looking for the library under /usr/local/lib/amd64,
> the file is located in /usr/local/openjdk7/jre/lib/amd64, I was able
> to work around the problem by creating a symbolic link to point
> /usr/local/lib/amd64 to /usr/local/openjdk/jre/lib/amd64, as the amd64
> sub-directory didn't exist in /usr/local/lib.
> This does make me wonder though, if I am just missing something from
> my environment, that's causing this.  Or is the port install not doing
> something that it should be doing?
> System is a new build of 9.2-RELEASE, compiled from source, source and
> ports all built with clang where possible.

Just an update, this only worked the first time I executed it, now all I 
get is:

/usr/local/openjdk7/jre/lib/amd64/libsplashscreen.so: Undefined symbol 

I somewhat worked around it by installing the linux_sun_jre 7.40, and 
pointing icedtea webstart at it, searching online shows this to be most 
likely be a bug in the port of openjdk.


    Dean E. Weimer

More information about the freebsd-questions mailing list