GNUPG fails to build on FreeBSD 10.0-BETA3

Gerard Seibert jerry at
Sat Nov 16 12:06:29 UTC 2013

> -----Original Message-----
> From: Herbert J. Skuhra [mailto:hskuhra at]
> Sent: Saturday, November 16, 2013 5:38 AM
> To: Gerard Seibert
> Cc: freebsd-questions at; kuriyama at
> Subject: Re: GNUPG fails to build on FreeBSD 10.0-BETA3
> On Fri, 15 Nov 2013 18:18:43 -0500
> Gerard Seibert wrote:
> > I have tried to build gnupg-2.0.22 on FreeBSD 10.0-BETA3 twice and
> > both attempts failed. This is a fresh install of FreeBSD on a totally
> > clean drive. This is the output at the end of the build attempt.
> >
> > checking for LIBFFI... no
> > configure: error: Package requirements (libffi >= 3.0.0) were not met:
> >
> > Package libffi was not found in the pkg-config search path.
> > Perhaps you should add the directory containing `libffi.pc'
> > to the PKG_CONFIG_PATH environment variable Package 'libffi', required
> > by 'world', not found
> >
> > Consider adjusting the PKG_CONFIG_PATH environment variable if you
> > installed software in a non-standard prefix.
> Subject is wrong! devel/glib20 fails to build, not security/gnupg!
> Does /usr/local/libdata/pkgconfig/libffi.pc exist?
> Have you tried to rebuild devel/libffi?

Okay, "libffi.pc" did not exist. "devel/glib20" was failing to build and 
then subsequently "/security/gnupg" due to this fact. I built "devel/libffi" 
and then preceded to building "gnupg". It is building now and appears to be going well.

Obviously, there is a dependency problem.  Now, should I file a PR and if so, against which port? Since "devel/glib20" was not pulling in "libffi" I would assume "glib20" is the port to report.

Thanks for your assistance.


More information about the freebsd-questions mailing list