GNUPG fails to build on FreeBSD 10.0-BETA3

Herbert J. Skuhra hskuhra at
Sat Nov 16 10:37:53 UTC 2013

On Fri, 15 Nov 2013 18:18:43 -0500
Gerard Seibert wrote:

> I have tried to build gnupg-2.0.22 on FreeBSD 10.0-BETA3 twice and
> both attempts failed. This is a fresh install of FreeBSD on a
> totally clean drive. This is the output at the end of the build
> attempt.
> checking for LIBFFI... no
> configure: error: Package requirements (libffi >= 3.0.0) were not met:
> Package libffi was not found in the pkg-config search path.
> Perhaps you should add the directory containing `libffi.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'libffi', required by 'world', not found
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.

Subject is wrong! devel/glib20 fails to build, not security/gnupg!

Does /usr/local/libdata/pkgconfig/libffi.pc exist?
Have you tried to rebuild devel/libffi?


More information about the freebsd-questions mailing list