ERROR - Cannot get GEOM tree

Adam Vande More amvandemore at
Mon Nov 4 18:34:34 UTC 2013

On Mon, Nov 4, 2013 at 12:24 PM, Drew Tomlinson <drew at>wrote:

> I've been happily running FBSD on a HP e60 Netserver for the past 13
> years.  It's been so reliable, I've tended to just forget about it. However
> after a power outage, it will no longer boot.
> I've done some testing and got it booted with a 9.2 LiveCD.  I think the
> version of FBSD on this box is 6.4.  It has two 9 GB SCSI drives that I had
> striped using gstripe.  I think one of those drives has died but would like
> to confirm before giving up.
> I've tried rewriting the MBR to both disks using "fdisk -B -b /boot/boot0
> daX" but get this error:
> Cannot get GEOM tree: Illegal byte sequence
> I've also tried "gstripe list" but get the same error.
> My stripe is "/dev/stripe/data" so I tried mounting it with "mount
> /dev/stripe/data /mnt/data".  I get this error:
> mount: /dev/stripe/data: R/W mount of /usr denied. Filesystem is not clean
> - run fsck.: Operation not permitted
> So I tried to run "fsck /dev/stripe/data".  Another error:
> fsck: Could not determine filesystem type
> I suspect one or both members of my stripe are dead.  Can anyone confirm?
>  Is there anything else I can check before giving up?

There should be related messages in dmesg and /var/log/messages.


More information about the freebsd-questions mailing list