Help! Cannot boot after freebsd-update update to 9.1-p5

Brett Glass brett at
Sun Jul 28 20:57:47 UTC 2013

Help! I just used freebsd-update to upgrade a system to FreeBSD 
9.1-RELEASE-p5 to close the latest security holes. I then rebuilt 
my custom kernel and tried to reboot. I'm now getting the message

Can't work out which disk we are booting from.
Guessed BIOS device 0xffffffff not found by probes, defaulting to disk0:

at boot time.

The strange thing is that when I boot the system from a FreeBSD 9.1 
(AMD64) USB key, I can mount and read the file system on the hard 
drive that will not boot. There doesn't seem to be any problem with 
it. I've tried copying /boot/loader over from the USB key; still 
can't boot. Tried moving the GENERIC kernel over from the USB key 
into /boot/kernel, just in case there was a problem with my custom 
one; still can't boot. Not sure what to try next. Any ideas would 
be much appreciated!

--Brett Glass

More information about the freebsd-questions mailing list