ZFS root, error 2 when mounting root

bw.mail.lists bw.mail.lists at gmail.com
Sun Feb 24 09:42:27 UTC 2013

Basically, I tried to follow 
https://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/9.0-RELEASE, but ended up 
with a system that didn't know how to mount /.

There are two scripts attached.

zfsnocache.sh follows the instructions on the wiki. The system booted 
just fine, but when it got to the part where it mounts the root 
partition, it stopped with 'error 2' 'unknown file system'. I could 
import the pool when booting from LiveFS, I wrote to it, it was working 
fine, but at boot it just refused to be mounted as /.

zfswithcache.sh from http://strahlert.net/wordpress/?p=142, I think. 
This worked with no issues.

The main difference I see between those two scripts is that one doesn't 
use a cache file and the other one does, hence the name of the scripts. 
But it should work without cachefile too, shouldn't it? The other 
difference is how mountpoints are set, but I can't figure out what could 
be wrong there.

Can someone please explain why zfsnocache fails to mount / ?

More information about the freebsd-questions mailing list