Xorg not working with radeon on 10 stable

David Collins davidcollins001 at gmail.com
Mon Dec 30 01:18:46 UTC 2013

On 29 Dec 2013 16:28, "Warren Block" <wblock at wonkity.com> wrote:
> David Collins wrote:
>> I have recently upgraded from 9 stable to 10 stable. The intention was
to install an updated version of xbmc which was quite out of date. I
upgraded from source the usual way and upgraded my ports as is suggested at
the bottom of the portmaster man page (delete everything and re-build).
> (Your message showed only as an "OCTET-STREAM" attachment, repasted here
as text.)

I'm not sure why my email came through it did, but thanks for replying.

> I did a similar upgrade recently also.
>> I have a Radeon HD 2400 PRO/XT, which supported from whats in the log
>> file.  The user is as member of the dri group. I load the radeonkms
>> kernel module on boot.
> That is not necessary, and causes problems for some.

Noted, will remove.

>> When try to start X (same xorg.conf file that
>> worked previously or with newly created xorg.conf) the xserver gives
>> me a black screen which I can't do anything with, I am also unable to
>> switch virtual terminals.
> This is a known problem with the KMS drivers.  The new console drivers
fix this, hopefully to be MFCed soon after 10.0-RELEASE.

Brilliant, I look forward to this

>> I can ssh in to get access. My make.conf, xorg.conf and Xorg log file
are below but the bits that look suspect are:
>> [   127.760] (II) AIGLX: Screen 0 is not DRI2 capable
>> [   128.363] (EE) AIGLX error: r600 does not export required DRI
>> I have found a number of reports of this with linux but no solutions
>> that I have been able to use. Does anyone have any idea how to solve
>> this?
> Use the ati or radeon driver, not radeonhd, which is obsolete.

I tried the ati driver (with updated xorg.conf) from ports but i don't
think it worked either. I won't have access to my computer for a couple
days but when I do I will try again.


More information about the freebsd-questions mailing list