jail.conf ignoring exec.fib?

Karl Pielorz kpielorz_lst at tdx.co.uk
Tue Aug 20 11:50:30 UTC 2013

--On 20 August 2013 08:27 +0100 Arthur Chance <freebsd at qeng-ho.org> wrote:

> In the source the exec.fib parameter is given as an integer, so the
> quotes probably shouldn't be there, but I'm not sure whether it matters.

I tried it just as 'exec.fib = 1;' originally, and it makes no difference :(

> There's definitely a setfib call in the source that's done if exec.fib
> exists. All I can think of right now is that you try firing up the jail
> using the -v verbose flag. This should show everything the jail command
> does as the jail is created.

Ok, I tried that and got:

root# jail -v -c jail
jail: run command: /sbin/mount -t devfs -oruleset=4 . /usr2/jails/jail/dev
jail: jail_set(JAIL_CREATE) persist name=jail devfs_ruleset=4 jid=100 
path=/usr2/jails/jail host.hostname=jail.somedomain.com 
ip4.addr= allow.raw_sockets
jail: created
jail: run command in jail: /bin/sh /etc/rc
Setting hostname: jail.somedomain.com
ELF ldconfig path: /lib /usr/lib /usr/lib/compat /usr/local/lib
32-bit compatibility ldconfig path: /usr/lib32
Creating and/or trimming log files.
ln: /dev/log: Operation not permitted
Starting syslogd.
Clearing /tmp (X related).
Updating motd:.
Starting cron.

Tue Aug 20 11:39:20 UTC 2013
jail: jail_set(JAIL_UPDATE) jid=100 nopersist

Certainly more detail, but no mention of fib's :( - I tried it both with, 
and without quotes around the FIB value. You can also see I have raw 
sockets available for debugging.


More information about the freebsd-questions mailing list