ZFS Snapshots Not able to be accessed under .zfs/snapshot/name

Shane Ambler FreeBSD at ShaneWare.Biz
Thu Aug 15 02:43:51 UTC 2013

On 14/08/2013 22:57, dweimer wrote:
> I have a few systems running on ZFS with a backup script that creates
> snapshots, then  backs up the .zfs/snapshot/name directory to make sure
> open files are not missed.  This has been working great but all of the
> sudden one of my systems has stopped working.  It takes the snapshots
> fine, zfs list -t spnapshot shows the snapshots, but if you do an ls
> command, on the .zfs/snapshot/ directory it returns not a directory.
> part of the zfs list output:
> NAME                        USED  AVAIL  REFER  MOUNTPOINT
> zroot                      4.48G  29.7G    31K  none
> zroot/ROOT                 2.92G  29.7G    31K  none
> zroot/ROOT/91p5-20130812   2.92G  29.7G  2.92G  legacy
> zroot/home                  144K  29.7G   122K  /home
> part of the zfs list -t snapshot output:
> NAME                                            USED  AVAIL  REFER
> zroot/ROOT/91p5-20130812 at 91p5-20130812--bsnap   340K      -  2.92G  -
> zroot/home at home--bsnap                           22K      -   122K  -
> ls /.zfs/snapshot/91p5-20130812--bsnap/
> Does work at the right now, since the last reboot, but wasn't always
> working, this is my boot environment.
> if I do ls /home/.zfs/snapshot/, result is:
> ls: /home/.zfs/snapshot/: Not a directory
> if I do ls /home/.zfs, result is:
> ls: snapshot: Bad file descriptor
> shares
> I have tried zpool scrub zroot, no errors were found, if I reboot the
> system I can get one good backup, then I start having problems.  Anyone
> else ever ran into this, any suggestions as to a fix?
> System is running FreeBSD 9.1-RELEASE-p5 #1 r253764: Mon Jul 29 15:07:35
> CDT 2013, zpool is running version 28, zfs is running version 5

I can say I've had this problem. Not certain what fixed it. I do 
remember I decided to stop snapshoting if I couldn't access them and 
deleted existing snapshots. I later restarted the machine before I went 
back for another look and they were working.

So my guess is a restart without existing snapshots may be the key.

Now if only we could find out what started the issue so we can stop it 
happening again.

More information about the freebsd-questions mailing list