x11-toolkits/open-motif build issue

Gary Aitken vagabond at blackfoot.net
Sat Aug 3 22:07:12 UTC 2013

Hi all,

I'm running a newly upgraded 9.1.
Did a portmaster -a to rebuild what I had up to a point,
then tried building x11-toolkits/open-motif,
as it is the component which failed when trying to build editors/openoffice-3.

Seeing the same error I was seeing under 9.0.
I suspect this is something screwed up in the environment but haven't a clue
what it is.
It looks like crt1.o is being included in the library build by mistake,
and that's causing the undefined ref to _main.




gmake[1]: Entering directory `/usr/ports/x11-toolkits/open-motif/work/motif-2.3.4/tools'
Making all in wml
gmake[2]: Entering directory `/usr/ports/x11-toolkits/open-motif/work/motif-2.3.4/tools/wml'
/bin/sh ../../libtool  --tag=CC   --mode=link cc  -O2 -pipe -fno-strict-aliasing -std=gnu89 -Wall -g -fno-strict-aliasing -Wno-unused -Wno-comment -fno-tree-ter -DCSRG_BASED -DXNO_MTSAFE_API -DXNO_MTSAFE_PWDAPI -D_THREAD_SAFE -I/usr/local/include/freetype2 -I/usr/local/include      -L/usr/local/lib -o wmluiltok wmluiltok.o  -lXp -liconv  -L/usr/local/lib -lXft -lXrender  -L/usr/local/lib -lXft   -ljpeg -lpng
libtool: link: cc -O2 -pipe -fno-strict-aliasing -std=gnu89 -Wall -g -fno-strict-aliasing -Wno-unused -Wno-comment -fno-tree-ter -DCSRG_BASED -DXNO_MTSAFE_API -DXNO_MTSAFE_PWDAPI -D_THREAD_SAFE -I/usr/local/include/freetype2 -I/usr/local/include -o wmluiltok wmluiltok.o  -L/usr/local/lib /usr/local/lib/libXp.so /usr/local/lib/libXext.so /usr/local/lib/libiconv.so /usr/local/lib/libXft.so /usr/local/lib/libfontconfig.so /usr/local/lib/libexpat.so /usr/local/lib/libfreetype.so -lz -lbz2 /usr/local/lib/libXrender.so /usr/local/lib/libX11.so /usr/local/lib/libxcb.so /usr/local/lib/libXau.so /usr/local/lib/libXdmcp.so /usr/local/lib/libpthread-stubs.so -lrpcsvc /usr/local/lib/libjpeg.so -lpng -pthread -Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib
/usr/lib/crt1.o: In function `_start':
crt1.c:(.text+0x8a): undefined reference to `main'
gmake[2]: *** [wmluiltok] Error 1
gmake[2]: Leaving directory `/usr/ports/x11-toolkits/open-motif/work/motif-2.3.4/tools/wml'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/x11-toolkits/open-motif/work/motif-2.3.4/tools'
gmake: *** [all-recursive] Error 1
*** [do-build] Error code 1

Stop in /usr/ports/x11-toolkits/open-motif.

More information about the freebsd-questions mailing list