Removing UFS label from root

Warren Block wblock at
Mon Sep 10 03:00:22 UTC 2012

On Sun, 9 Sep 2012, Kevin Oberman wrote:

> On Sun, Sep 9, 2012 at 6:49 PM, Warren Block <wblock at> wrote:
>> On Sun, 9 Sep 2012, Warren Block wrote:
>>> On Sun, 9 Sep 2012, Kevin Oberman wrote:
>>>> I added a label to my root fs some time ago. I really prefer the gpt
>>>> label and I have added it, but I can't figure out how to remove the
>>>> ufs label.
>>>> I boot single user and run 'tunefs -L "" /dev/ada1p2' but I get an
>>>> "unable to write superblock" error. This is before mounting the drive
>>>> RW, but it is, of course, mounted RO.
>>> This worked in a VM when I tested it just now.  Maybe running fsck on that
>>> filesystem first will help.
> Already tried that.
> I know I was able to label it originally, so it does seem like
> something must have changed, but I don't know what. I did use gpart to
> expand my /usr partition and then used growfs to expand the FS, but I
> did nothing to root and I was able to remove the labels on all of the
> other partitions.

Might there be a duplicate filesystem label of "root" on ada0 or another 

More information about the freebsd-questions mailing list