Removing UFS label from root

Kevin Oberman kob6558 at
Mon Sep 10 02:50:25 UTC 2012

On Sun, Sep 9, 2012 at 6:49 PM, Warren Block <wblock at> wrote:
> On Sun, 9 Sep 2012, Warren Block wrote:
>> On Sun, 9 Sep 2012, Kevin Oberman wrote:
>>> I added a label to my root fs some time ago. I really prefer the gpt
>>> label and I have added it, but I can't figure out how to remove the
>>> ufs label.
>>> I boot single user and run 'tunefs -L "" /dev/ada1p2' but I get an
>>> "unable to write superblock" error. This is before mounting the drive
>>> RW, but it is, of course, mounted RO.
>> This worked in a VM when I tested it just now.  Maybe running fsck on that
>> filesystem first will help.

Already tried that.

I know I was able to label it originally, so it does seem like
something must have changed, but I don't know what. I did use gpart to
expand my /usr partition and then used growfs to expand the FS, but I
did nothing to root and I was able to remove the labels on all of the
other partitions.

> Alternative thought: is ada1p2 actually a UFS filesystem?

Well, the fact that it has a ufs label, fstab show ufs and fsck runs
fsck_ufs are strong hints.
2. Name: ada1p2
   Mediasize: 1073741824 (1.0G)
   Sectorsize: 512
   Stripesize: 4096
   Stripeoffset: 0
   Mode: r1w1e2
   rawuuid: 43f0eafd-ba3a-11e0-b70a-f0def166a11e
   rawtype: 516e7cb6-6ecf-11d6-8ff8-00022d09712b
   label: root
   length: 1073741824
   offset: 86016
   type: freebsd-ufs
   index: 2
   end: 2097319
   start: 168
R. Kevin Oberman, Network Engineer
E-mail: kob6558 at

More information about the freebsd-questions mailing list