Famp Server

Michael Powell nightrecon at hotmail.com
Wed Oct 31 17:22:41 UTC 2012

Hamisi Jabe wrote:

> i started installing apache22 and it worked, then i installed mysql it
> worked fine, also when i installed php5 it worked fine too but when i
> browse php file it displays the codes not the information like i created a
> php file to display the current settings <?php echo phpinfo();  ?> in the
> /usr/local/www/apache22/data directory
> i did everything as root
> http://www.iceflatline.com/2011/11/how-to-install-apache-mysql-php-and-
>  check this tutorial which i used to configure the famp on my server

Under the <IfModule mime_module> section in you httpd.conf try adding:

        AddType application/x-httpd-php .php
        AddType application/x-httpd-php-source .phps

and restart Apache. Also double check that the Apache PHP module was 
installed when you built PHP. There will be a line like the following:
LoadModule php5_module        libexec/apache22/libphp5.so


More information about the freebsd-questions mailing list