NVIDIA proprietary driver error

Shane Ambler FreeBSD at ShaneWare.Biz
Mon Oct 29 04:33:21 UTC 2012

On 26/10/2012 19:06, Ashkan Rahmani wrote:

>>  i have an option in bios "boot vga controller selection for" which
>> have 2 options windows 7/vista and reserved.

> Thank you for reply,
> That xorg.conf generetaed by Xorg -configure.
> yes I tried nvidia-xsetting. On start I got error which says "There is not
> any compatible device detected" or some things like this.
> nvidia-xconfig generate very simple xorg.cong with just one screen or
> monitor, sets nvidia as driver, but not work.
> I got same error (in /var/log/xorg.0.log) actually: no device detected.
> Beside all of this stuffs, There is a point, BusID, Xorg -configure set
> BusID to "PCI:1:0:0" and nvidia-xconfig set  it "PCI:0:2:0"
> Because Xorg generated xorg.conf works (of course with incorrect resolution
> and with lag) I changed BusID in nvidia-xconfig "PCI:0:2:0" to "PCI:1:0:0".
> not worked!
> May be error come from NVIDIA Optimus.

Did changing the bios settings help?

I have come across some more info - it is an issue with optimus which is 
a technology to allow switching between lower power usage intel graphics 
and higher performing nvidia graphics. I didn't hear any certainty about 
turning it off in bios but there is a record of linux not supporting it. 
A project called bumblebee targets getting support on linux.

The two busid's reflect the intel and nvidia devices - did you try 
removing nvidia and using only the intel settings?

More information about the freebsd-questions mailing list