NVIDIA proprietary driver error

Shane Ambler FreeBSD at ShaneWare.Biz
Fri Oct 26 08:14:34 UTC 2012

On 25/10/2012 19:52, Ashkan Rahmani wrote:

> On Oct 25, 2012 12:02 PM, "Shane Ambler" <FreeBSD at shaneware.biz>
> wrote:
>> On 25/10/2012 17:34, Ashkan Rahmani wrote:
>>> Hi, I'm going to install driver for nvidia 310M cuda enabled, but
>>> I have some problem with it.
>>> Monitor resolution must be 1366x768 xxx but resolution is  1024x768
>>> and with lag.
>> Sounds like your on a laptop? model details could be helpful if
>> someone else has tried on that machine.

> yes it is asus k52j' no there is not second monitor. and i have just
> screen0 in xorg config file. what you mean from second gpu?? driver
> is nvidia. resolution not set.

There are a few K52J variations - the K52JC has the 310M

In the xorg.conf you posted the link to - you have two parts titled -
Section "Device" - one has card0 nvidia the other has card1 intel.
You also have two sections for Screen and two for Monitor.
In the ServerLayout you have
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"

My guess is that the cpu has a built-in gpu. The asus details list four
corei5 options - intel says 3 of them include HD graphics see last
table here -

Just wondering if the two gpu's might be creating a conflict.

>> I would try removing the screen 1 line from serverlayout as well as
>> the matching screen and monitor 1 details as well as the intel
>> graphics device section - disconnecting a second monitor if it is
>> connected.
>> Change Driver "nv" to Driver "nvidia" and try that.
> xorg.conf which generated by xorg -configure detect vga vendor name
> as intel corporation, and set driver vesa. when i change driver to
> any thing else i got no devices detected error. please attention i
> have label on laptop body says vga is nvidia geforce 310m cuda 1gb,
> and another label with nvidia optimus.

Have you tried running nvidia-xconfig? x11/nvidia-xconfig
or nvidia-settings? x11/nvidia-settings

> i have an option in bios "boot vga controller selection for" which
> have 2 options windows 7/vista and reserved.

Try changing to reserved.

You may also want to try removing the nvidia sections from xorg.conf
and see if you can get the intel gpu to work.

Also when you reply, use reply to all so that a copy also goes to the
list. It can increase your chance of someone helping.

More information about the freebsd-questions mailing list